Chinese Diesel Heater Wiring Problems?

Hey everyone!

We purchased a knock off 12V diesel heater because we heard they work just as well if not better than the espar… However, the instructions aren’t helpful. I don’t think it translated well because none of the sentences make any sense.

As far as I can tell, everything is hooked up correctly and connected well. But the wiring isn’t working. I get my power through to the first plug and then it seems to disconnect. No power seems to be going through the plug to the pump or the LED screen. I’ve tested the power inside the plug on the connectors, but when plugged in nothing happens.

Has anyone else experienced this issue? Any help on this would be greatly appreciated! Thanks!

1 Like


I would scour the net, including youtube, to find some decent directions for installing your heater. Even other brands may be the same heater…


"Opportunities are everywhere, but only action makes it happen." ~ Van_Dweller


I’ve heard that the Chinese heater instructions are useless, but also heard that there are good tutorials via YouTube etc.

I kept it very simple by investing in a heater that doesn’t require electricity, but it requires more work to operate.


I am a believer in non electric solutions for everything possible. While I have a number of 12v luxury/convenience items that I enjoy, my only electrical requirements are my phone & laptop, and both of them can be charged only while driving if necessary.


"Opportunities are everywhere, but only action makes it happen." ~ Van_Dweller

Hi Elise,
I know it’s a while since you posted this, but I’m having exactly the same problem with my new install, and, having scoured the net, happened upon your post!

Did you manage to sort it in the end? There doesn’t seem to be much out there for faultfinding this problem. I’ve ascertained that there is power going to the first plug, but there’s nothing on the terminal for the red (I’m assuming live) cable that goes from that first plug and then down to the controller.

Hoping that you got yours all runnning without too much further hassle, and can hopefully help me with the same issue please?


Hey there Dwight!

I honestly do not recall what the issue was. I know that At one point we had an extra circuit breaker between our MPPT controller and our batteries that was causing a drop in power when we turned anything on. Once we took the extra circuit breaker out it solved a lot of unknowns, but I don’t recall if that was a solution to the heater problem.

I would recommend double checking that you haven’t mixed up a couple wires, and possibly blew a fuse. I recall similar problems with the wire colors, and not being sure which is the live wire or not. I would also double check that you have the correct size fuse, as I know that we messed with that a lot during the install as well. I do remember that the solution was simple and something I was just overthinking, so hopefully walking away and coming back to the project later helps.

We did get ours running and it works great! We’ve been comfortable sleeping in the van with temps outside as low as -6F. We’re on instagram and Facebook as @freedomoffthegrid, you can dm me any other questions you have or maybe pictures and I’ll try my best to help!!

Hey Elise,

Thanks so much for getting back to me and so quickly!

So I managed to fault find and sort out a couple of problems with the plugs. There was a bent pin in one (which is probably why it was so hard to get it to click shut in the first instance), and there was also a positive wire in one of the plugs that didn’t correspond with the positive wire from the other plug. Once I bent the pin back into a neutral position, and move the wire over to the correct position, it all worked a dream!

Thanks again for your reply, and for the info on your instagram and Facebook feeds. I’ll definitely check them out and DM you if something else comes up :smiley:

Yay!!! I’m so happy you got it working! :grin: